Home > F/OSS, Linux, News > Ubuntu 7.10 – Partial Fix – Getting Compiz working

Ubuntu 7.10 – Partial Fix – Getting Compiz working

Well, as promised I am posting how to get the various bits of Ubuntu working with a Amilo a1650 laptop. In my previous post I outlined the areas that immediately let down the release and in this post I am going to briefly detail how to get the advanced compositing effects working.

The window decorator compiz refused to run, crashing with the error “No whitelisted driver found”. Before I went any further I checked to see if my restricted repository ATi binary driver was working properly.

Both “fglrxinfo” and “grep glxinfo | grep “direct rendering”” indicated that it had.

So I followed the advice of this thread and proceeded to install the xgl server (via : sudo apt-get install xserver-xgl)

and make sure compiz and all its managers / dependencies were correctly installed:

sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

After this I restarted the session (using Ctrl+Alt+Backspace) and used the console to test compiz via

compiz –replace” – Note there are two hyphens although for some reason wordpress is only showing one.

which then loaded, replaced metacity and worked perfectly.

Advertisements
Categories: F/OSS, Linux, News Tags: , , , , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: