Archive

Posts Tagged ‘amilo’

Ubuntu on the A1650

June 23, 2008 1 comment

Despite some rather exciting progress made of late getting Linux to work on the Fujitsu Siemens Amilo A1650, regretably after three weeks of using it, I am back to Vista. The reason for this is my conclusion that running Linux (more specifically, Ubuntu) on the A1650 is a painful process due to the maturity of hardware support. Its (finally) possible to get all the hardware working, unfortunately doing so feels cumbersome and unnatural. The biggest culprits are the graphics card (an ATi x200m) and the wireless (Broadcom 4318 mini PCI) card.

The ATi graphics card has long been criticised as being ‘defective by design’. Getting any hardware accelerated graphics on this laptop formerly required running XGl with a long series of complicated hacks and even then it was not possible to run desktop compositing effects like Beryl or Compiz. Eight (or so) Months ago, that changed with a redesign of the X Server (in X.org 7.0) when XGL back rendering was no longer required for hardware accelerated rendering. More than that, it greatly simplified the process meaning even the most inexperienced Linux user could have beautiful desktop effects, in some cases, out of the box. However, due to an annoying glitch somewhere, the ATi restricted drivers caused diagonal tearing whenever a window rapidly refreshed itself.

It says something about the maturity of hardware support under Linux when Vista, commonly (and unjustly) thought of a resource hog, runs better. Anyway, this is all academic now as I have retired my Amilo A1650. Its been a great laptop but after three years it was time to move on. I will play with Linux on my new laptop soon and post the results.

Ubuntu 7.10 – Partial Fix – Getting Compiz working

December 24, 2007 1 comment

Well, as promised I am posting how to get the various bits of Ubuntu working with a Amilo a1650 laptop. In my previous post I outlined the areas that immediately let down the release and in this post I am going to briefly detail how to get the advanced compositing effects working.

The window decorator compiz refused to run, crashing with the error “No whitelisted driver found”. Before I went any further I checked to see if my restricted repository ATi binary driver was working properly.

Both “fglrxinfo” and “grep glxinfo | grep “direct rendering”” indicated that it had.

So I followed the advice of this thread and proceeded to install the xgl server (via : sudo apt-get install xserver-xgl)

and make sure compiz and all its managers / dependencies were correctly installed:

sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

After this I restarted the session (using Ctrl+Alt+Backspace) and used the console to test compiz via

compiz –replace” – Note there are two hyphens although for some reason wordpress is only showing one.

which then loaded, replaced metacity and worked perfectly.

Categories: F/OSS, Linux, News Tags: , , , , ,
Follow

Get every new post delivered to your Inbox.

%d bloggers like this: